TLS 1.0 은 1999년, 1.1은 2006년, 1.2는 2008년, 1.3은 2018년에 나왔습니다.

 

1999년, 2006년에 나온 기술을 아직까지 쓰고 있다니 정말 오래됐네요.

 

빠르면 내년 1월부터 SSL TLS 1.0과 1.1이 브라우저에서 더이상 지원을 하지 않습니다.

물론 보안 관련 문제구요.

 

*웹 브라우저

그래서 TLS 1.2 이상을 지원하는 웹브라우저를 사용하시는게 좋습니다.

(크롬 30이상, 파이어폭스 24이상 -설정필요, IE 8,9,10 -설정 필요, 엣지, 사파리 7이상) 

 

*모바일

안드로이드 4.4.2부터 지원가능하나 SSL HandshakeException 버그 발생

안드로이드 4.4.2 (지원 가능) : https://www.ssllabs.com/ssltest/viewClient.html?name=Android&version=4.4.2

안드로이드 4.3 (지원 불가) : https://www.ssllabs.com/ssltest/viewClient.html?name=Android&version=4.3

 

 

 

애플 iOS는 5.11부터 지원합니다. 

iOS 5.11 (지원 가능) : https://www.ssllabs.com/ssltest/viewClient.html?name=Safari&version=5&platform=iOS%205.1.1

 

주요 브라우저별 지원 종료 예정 일정

1. 구글 크롬 (2020년 1월 예정)
https://www.chromestatus.com/feature/5654791610957824

2. 애플 웹킷 & 사파리 (2020년 3월 종료 예정)
https://webkit.org/blog/8462/deprecation-of-legacy-tls-1-0-and-1-1-versions/

3. 모질라 파이어폭스 (2020년 3월 종료 예정)
https://blog.mozilla.org/security/2018/10/15/removing-old-versions-of-tls/

4. MS 엣지, IE 11 (2020년 상반기 종료 예정)
https://blogs.windows.com/msedgedev/2018/10/15/modernizing-tls-edge-ie11/

 

TLS 1.2 적용 최소 환경
– APACHE 2.2.22 이상
- Nginx 1.1.13 이상
– Openssl 1.0.1 이상
– JAVA 7 이상
-Windows Server 2008 SP2 이상

 

Paypal - 2018년부터 이미 TLS 1.2와 HTTP/1.1 의무화

https://www.paypal.com/au/webapps/mpp/tls-http-upgrade

 

트위터 - 이미 지난 7월 말에 API에서 사용 중지 상태

https://twittercommunity.com/t/removing-support-for-legacy-tls-versions-1-0-1-1-on-twitter/126648/2

 

94%의 많은 곳들이 TLS 1.2를 지원

https://www.bleepingcomputer.com/news/security/tls-10-and-tls-11-being-retired-in-2020-by-all-major-browsers/

 

 

+ Recent posts